Перейти к содержанию
Fire Monkey от А до Я

Лидеры

  1. OnePeople

    OnePeople

    Пользователи


    • Баллы

      6

    • Постов

      363


  2. Barbanel

    Barbanel

    Пользователи


    • Баллы

      5

    • Постов

      419


  3. #WAMACO

    #WAMACO

    Пользователи


    • Баллы

      3

    • Постов

      776


  4. Vitaldj

    Vitaldj

    Пользователи


    • Баллы

      2

    • Постов

      847


Популярный контент

Показан контент с высокой репутацией 11.04.2019 во всех областях

  1. OnePeople

    Монополия

    Делал чисто для себя! И только для своего удовольствия! Возможны ошибки!*(вернее точно есть))) Графика не окончательная! Скриншоты сервер: Скриншоты клиент: Сервер на комп, клиент Android (должны находиться в одной сети) P/S И так как все устройства у меня Full HD, проверял только на них( Monopoly.rar
    3 балла
  2. В аттаче пример того как я себе представляю такую реализацию. Будем использовать в нашем проекте. Буду рад критике, предложениям, и все такое. TestWhatsNew.zip
    3 балла
  3. 1.Можно взять Rectangle, залить его с Alpha 70%. И поместить в него изображение. 2.Затем расчитать абсолютное положение контрола на форме, его размеры,сделать его скриншот. 3.Изображению задать соответствующие размеры, координаты и скриншот контрола, можно добавить свечение.
    2 балла
  4. 1. Сделать скриншот формы. 2. Показать новую форму с фоном скриншота (слегка размыв скриншот) 3. На новой форме лепить что душе угодно, переходы и т.д. 4. По окончании обучающего ролика, закрыть форму ролика и взвести флаг, что ролик показан! (для последующих не выводом ролика) это если изолированный ролик, как таковой. если нужны подсказки к контролам, то можно выводить кастомные toast-ы, например с помощью Layout и обычного Rectangle поверх.
    2 балла
  5. Как вариант - можете использовать внешнее приложение https://ffmpeg.org/ . И вроде можно использовать его библиотеки в своем приложении (но тут не скажу, не пробовал).
    1 балл
  6. Тоже свой вариант по быстрому накидал, как пример WhatNew.rar
    1 балл
  7. Я бы не делал скриншот. А просто поместил поверх прозрачный TPaintBox. А в OnPaint просто вычислил область ,которую не надо закрашивать и просто закрасил paintBox кистью с прозрачностью с учетом выреза.
    1 балл
  8. Кстати есть. TCircle Задайте ему размер и толщину Stroke и будет вам счастье)
    1 балл
  9. ну так, все что выше написали, оформите, как компонент и будет счастье! заодно потом и с нами поделитесь! :))
    1 балл
  10. Тоже задумывался об этом, правильного ответа не знаю, но мысли есть: Вариант 1 -сделать скриншот всего экрана (программно из дельфи, даже не экрана а формы) -затенить весь скриншот, предположим на 40-50% (т.е. снизить интенсивность каждого пикселя) -зная местоположение вашей кнопки с новой фичей, вырезать эту область из альфаканала скриншота (если делать круто - то вырез должен быть не прямоугольным а круглым, соотв. нужно както преобразовать прямоугольную кнопку в подходящих размеров круг) -вывести этот скришнот поверх всех контролов формы, не забыть положить на скриншот текст с описанием фичи и кнопкой перехода к следующей фиче. Вариант 2 -сделать скриншот всего экрана тупо чтобы знать его размеры -залить черным цветом -залить весь альфаканал на те же 40-50% (т.о. если вывести эту картинку поверх, она будет лишь затенять все что под ней) -аналогично предыдущему пункту вырезать дырку в альфаканале -аналогично предыдущему пункту вывести поверх формы Различия в том, что первый вариант вроде бы проще. Второй вариант зато позволит видеть анимированные контролы под затенением (если он и есть и нужны). Также буду раз услышать другие варианты.
    1 балл
  11. traylers

    VertScrollBox + StringGrid

    Все решилось interactivegestures.pan := false для StringGrid'ов
    1 балл
  12. Вы меня тоже поймите правильно, я ведь практический врач, не профессиональный программист. Нужно кое что доделать. Главное, что с использованием fgx, порог входа понижается. Все действительно, при понимании процессов, не так долго и работает весьма стабильно!
    1 балл
  13. Могу пока только дать саму презентацию, она в открытом доступе. https://www.dropbox.com/s/hjpj1dzpnedfjne/PharmControl.pptx?dl=0
    1 балл
  14. Протокол SNTP Помимо NTP, существует упрощенная версия этого протокола - SNTP (Simple Network Time Protocol). Он реализован для синхронизации времени конечным клиентом, поскольку все преимущества протокола NTP проявляются именно в сети серверов, а для получения показаний конечным пользователем NTP излишне сложен. Поэтому для синхронизации времени конечными компьютерами и серверами был предложен протокол SNTP (SNTPv3: 1992 г., RFC1361 и 1995 г., RFC1769; SNTPv4 включён как подпротокол в NTPv4). На самом деле SNTP - это не новый протокол, а способ использования NTP-пакетов и NTP-серверов в приложениях, где не требуется высокоточное время, либо оно недостижимо. В этом случае клиент использует только часть информации UDP-пакета NTP-сервера. SNTP-клиент может работать с любыми версиями NTP-серверов, и кроме них - с особыми SNTP-серверами, которые в откликах заполняют только необходимые данные UDP-пакета. Таким образом, "облегченный" SNTP образует не сеть синхронизирующихся серверов, а пары "клиент-сервер". Любой NTP-сервер является одновременно SNTP-сервером. Клиент, который не передаёт полученное время дальше, может работать как NTP- или SNTP-клиент, в зависимости от условий. Для SNTP, как и для NTP, зарезервирован 123-й UDP-порт. Uses IdSNTP, IdBaseComponent, IdComponent, IdUDPBase, IdUDPClient; .... procedure TForm1.Button2Click(Sender: TObject); Var IdSNTP: TIdSNTP; begin IdSNTP:=TIdSNTP.Create(Self); IdSNTP.Host := 'ntp1.stratum2.ru'; ShowMessage(DateTimeToStr(IdSNTP.DateTime)); IdSNTP.Free; end;
    1 балл
  15. TIdTime is a client implementation of the Time Protocol as described in the Internet Standards document:RFC 868 - Time Protocol (http://www.rfc-editor.org/rfc/rfc868.txt)Time is a simple protocol for synchronizing time on a local network. For a time protocol with higher accuracy over several networks, use TIdSNTP. To retrieve the current date and time in human-readable form, use TIdDayTime.Please note that the Time Protocol in its current form cannot handle most dates after the year 2035. This limitation is stated in RFC 868.
    1 балл
Эта таблица лидеров рассчитана в Москва/GMT+03:00
×
×
  • Создать...