• 0
Edward Tarasov

ancestor "object" not found

Вопросы

Чего то под конец написания диплома, вылазиет все больше и больше ошибок... еще одна!

Удалил не нужный layout - теперь пишет -'asentor for bron not found' , и так со всем чтобы не удалил - причем под винду компилиться норм, а с ведройдом беда! кто то сталкивался?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

10 ответов на этот вопрос

  • 0
5 часов назад, Edward Tarasov сказал:

Чего то под конец написания диплома, вылазиет все больше и больше ошибок... еще одна!

Удалил не нужный layout - теперь пишет -'asentor for bron not found' , и так со всем чтобы не удалил - причем под винду компилиться норм, а с ведройдом беда! кто то сталкивался?

Для решения вашей проблемы, надо в полнолуние заварить крепкий кофе, 3 раза посмотреть на северо-юг, кофе выпить, а гущу перед собой разложить. 

А если по делу, то кто это пишет и при каких действиях? 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
  • 0
В 11.03.2018 в 19:30, mazayhin сказал:

Для решения вашей проблемы, надо в полнолуние заварить крепкий кофе, 3 раза посмотреть на северо-юг, кофе выпить, а гущу перед собой разложить. 

А если по делу, то кто это пишет и при каких действиях? 

)) при любом удалении с формы компонента - вылетает такая ошибка.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
  • 0
27 минут назад, Edward Tarasov сказал:

)) при любом удалении с формы компонента - вылетает такая ошибка.

Ну давайте пример хотя бы посмотрим что там?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
  • 0
9 минут назад, mazayhin сказал:

Ну давайте пример хотя бы посмотрим что там?

забыл нажать сюда чтобы пилинькнуло)) при точ что ни bron ни где не учавствуют уже ни его дочерние элементы

Изменено пользователем Edward Tarasov

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
  • 0

Удаляете с фрейма? Где то мне подсказывают, мелькала подобная проблема

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
  • 0
14 минут назад, mazayhin сказал:

Удаляете с фрейма? Где то мне подсказывают, мелькала подобная проблема

удаляю с формы.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
  • 0

Фрейма или наследуемой формы там прямо точно нет?

На Берлине вот совсем не получается такое..

Или, может, правда гадалку позвать? Они и по скайпу, и по скринам нижней части бывает гадают

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
  • 1
В 14.03.2018 в 20:25, mazayhin сказал:

Фрейма или наследуемой формы там прямо точно нет?

На Берлине вот совсем не получается такое..

Или, может, правда гадалку позвать? Они и по скайпу, и по скринам нижней части бывает гадают

помоему нету там никаких фреймов - я же скинул скрины... единственное что есть это еще три формы, которые работают через use unit... но причем тут удаление компонентов на одной их них которые никак не взаимосвязаы я не пойму... я работаю в tokyo 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
  • 1
7 часов назад, Edward Tarasov сказал:

причем тут удаление компонентов

возможно, помимо master-view вы создали view под Андроид? А удалять пытаетесь с главного.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
  • 0

Создайте новый проект, и туда скопируйте код из старого. 

У меня такого поведения никода не было. Пишу под 4 платформы, в основном мобильные.

Изменено пользователем ENERGY

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти

  • Похожий контент

    • От SIARHEI RAHOUSKI
      При нажатии на Label действия не происходят
      procedure TForm2.Label11Click(Sender: TObject);
      begin
      Button1.visible:= true;
      {label7.Font.Style:= [];
      label8.Font.Style := [];
      label9.Font.Style := [];
      //label11.Font.Style := [fsbold];
      label10.Font.Style := [];  }

        GroupBox12.Visible := false;
        GroupBox13.Visible := false;
        GroupBox14.Visible := false;
        GroupBox15.Visible := true;
        GroupBox16.Visible := false;
      end;
    • От Edward Tarasov
      поставил этот патч 
      https://cc.embarcadero.com/item/30805
      Версия PAserver на mac стала - 10.1.1.37, test connection отвечает success, но при компиляции выдаеться ошибка - [PAClient Error] Error: E0014 Connection refused. Platform Assistant Server version mismatch - expecting version '10.0.1.23'. 
      10.0.1.23 - это старая версия PA... откатиться нельзя ибо не пашет, тоесть этот патч исправляет старую проблему - но добавляет эту... суть в том, как я понял после 4-х часовго гугления, что надо исправить PAclient, у которого версия почему то осталась старая... кто знает как с этим быть?
    • От Edward Tarasov
      Подскажите плз студенту, весь инет перерыл - ничего кроме tmapview не нашел, и тот позволяет только отображать маркеры и прокладывать через них маршрут... ок маршрут проложили а как включить навигацию? чтобы телка сказала - поверни те туда то.... не ясно, и возможно ли вообще такое? 
      Кстатить при использовании tmapview вместо карты - пустой экран.
      вообщем надо передать в tmapview мое местоположение и куда надо идти, затем включить навигацию
      Кто занет как сделать ?????????
      Или может есть возможность использовать встроенные возможности навигации?
    • От AliZairov
      Привет. Я сделал новую версию YouTubeApi компоненты. Поддерживаемые VCL & FMX + Mobile.
      Никаких официальных YouTube Api компоненты. Только данные с парсинг. Пример доступен в архиве.
       
      Новый
      ===
      v1.4 - 25/02/2018
        + Устранение проблем
      YouTubeApiDelphi
    • От Edward Tarasov
      Такая проблема... прога на андройд - два лэйаута в первом просто кнопки, во втором браузер. до тех пор пока второй лэйаут с браузером не открыли - кнопки в первом нажимаются - как только открыли браузер и закрыли его(visible:=false(и лэйаут и браузер)) кнопки в первом всеравно не нажимаются, как будто нажимаю на пустой лайаут, при том что сами кнопки на форме видно.
    • От sargon
      Добрый день, у меня есть один вопрос, делаю приложение в виде программы-мастера на FMX, в качестве страничек мастера использую TTabControl, случайно обнаружил, что при нажатии Tab+Ctrl вкладки переключаются, вроде так и должно быть, но мне вот такое поведение не подходит. Можно ли как-то отключить\заблокировать переключение вкладок по нажатию клавиш. Пробовал обрабатывать события KeyUp и KeyDown для TTabItem, но переключение вкладки происходит раньше, чем происходит вызов обработчика. Оно не критично конечно, но может быть кто-то сталкивался (если коротко, хочу переключать вкладки только по нажатию кнопок в программе)? Спасибо.
    • От Roman V
      Всем привет. Учусь работать с ini-файлами на Android. И сразу же возникла проблема, которую никак не могу решить. Хотел написать подобие приложение-тест с хранением данных в ini файле. В итоге все отлично работает на windows,а под Андроид при запуске висит только значок firemonkey секунд 10 и приложение вырубается так и не запустившись. В чем может быть проблема? Использую отладку по USB. 
      TIniFile *Ini = new TIniFile(System::Ioutils::TPath::GetDocumentsPath() + PathDelim + "options.ini"); Юзаю эти библиотеки 
      #include <System.IOUtils.hpp> #include <System.IniFiles.hpp>  
    • От Rustam Bikeev
      Суть проблемы следующая: после перехода с одной вкладки на другую в tabcontrol страница не отображается, фактически она переключается но на экране отображается предыдущая вкладка с которой был переход, ровно до той поры пока на что нибудь не клацнешь, нужно либо нажать на кнопку в тулбаре либо открыть multiview. После того как я первый раз с этим столкнулся я так и делал программно открывал и закрывал multiview, но не могу же я так делать постоянно, нужно решить проблему. Для подробности напишу, что есть основной tabcontrol в котором вкладки открываются из multiview, во вкладках есть вложенные tabcontrol-ы, со своими страницами в основном по 2 страницы. 
      Зря я начал делать приложения в делфи... чем дальше в лес тем больше дров.
    • От Alex7wrt
      Добрый день
      Как заставить TMediaPlayer воспроизводить MPG файлы под Windows? MP4 воспроизводит, а mpg не хочет. Установлены кодеки KLite.
      Добавление строки 
      TMediaCodecManager.RegisterMediaCodecClass('.mpg', 'MPEG Video', TMediaType.Video, TWindowsMediaCodec); не помогает. 
  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу