Перейти к содержанию

Новый пользователь

Пользователи
  • Активность

    10
  • Зарегистрирован

  • Посещение

Информация о Новый пользователь

  • Звание
    Пользователь

Посетители профиля

Блок последних пользователей отключён и не показывается другим пользователям.

  1. Вот рабочий код не забываем delphi 10 Seattle:Project-View sourceтам между FMX.Forms, и Unit1 in 'Unit1.pas' {Form1},вставляем: FMX.Helpers.Android, Androidapi.JNI.App, Androidapi.JNI.GraphicsContentViewText, Androidapi.Helpers, Androidapi.JNI.JavaTypes, Androidapi.JNIBridge, Androidapi.JNI.Telephony, Androidapi.JNI.Provider , =============================================== unit Unit1; interface uses System.SysUtils, System.Types, System.UITypes, System.Classes, System.Variants, FMX.Types, FMX.Controls, FMX.Forms, FMX.Graphics, FMX.Dialogs, FMX.Layouts, FMX.Edit, FMX.Controls.Presentation, FMX.StdCtrls, Androidapi.JNI.JavaTypes, Androidapi.Helpers, Androidapi.JNI.GraphicsContentViewText,FMX.Platform.Android, Androidapi.JNI.Telephony, Androidapi.JNI.Provider , Androidapi.JNIBridge, FMX.Helpers.Android; type TForm1 = class(TForm) Button1: TButton; Edit1: TEdit; Layout1: TLayout; Layout2: TLayout; procedure Button1Click(Sender: TObject); private { Private declarations } public { Public declarations } end; var Form1: TForm1; implementation {$R *.fmx} procedure TForm1.Button1Click(Sender: TObject); var obj: JObject; tm: JTelephonyManager; identifier: string; begin obj := SharedActivityContext.getSystemService(TJContext.JavaClass.TELEPHONY_SERVICE); if obj <> nil then begin tm := TJTelephonyManager.Wrap((obj as ILocalObject).GetObjectID); if tm <> nil then identifier := JStringToString(tm.getDeviceId); end; if identifier = '' then identifier := JStringToString(TJSettings_Secure.JavaClass.getString(SharedActivity.getContentResolver, TJSettings_Secure.JavaClass.ANDROID_ID)); Edit1.Text:= 'IMEI : '+identifier; end; end. Готовый код проект https://disk.yandex.ru/d/XkL7nnDj0lVKbAКак получить IMEI.rar
  2. Чеза издевательство с этой 4 версией блин 7 андройд , все sdk устовил не в какую не хочет работать приложение http://joxi.ru/Dr8vndDhob68g2 , уж все перепробовал не хрена
  3. А как насчёт киви на пайтоне не кодил.. Вот думаю может на нем делать приложения, или андррйд студио на котлин, джаву учил так нечего в ней и не понял, сложный язык, говорят котлин попроще, чем то на пайтон похож. ПРРСТО В ДЕЛФИ ТЕПЕРЬ ПРИДЁТСЯ И НА 2 ДЕЛФИ ПОД СТАРЫЕ ПИСАТЬ И С 4 Й ПОД НОВЫЕ, НЕ УДОБНЯК
  4. А вот теперь понял с 6 й версии, только не пойму зачем тогда было заносить толс sdk 4-5 версию в делфи 10.4 если они это даже не поддерживают
  5. Неужели на 10.4 не работает на 5 х версиях андройд, в тулс sdk то можно же ставить эти пакеты У многих телефоны с 5 - й версией андррйд, доже многие эмуляторы на этой версии
  6. Капец какой то на RAD Studio 10.4 на старых версиях андройд не идет приложение скампиленное на RAD Studio 10.4 на 10 -м и 11 -м идет даже под старую версию 5.11 SDK скачал все ровно ошибка что в эмуляторе что на андройде , хрень как то http://joxi.ru/eAOl4Lbh9gqZWr уже все перепробовал на старых версиях с RAD Studio 10.4 не идет не в какую , вроде все правильно настроил .
  7. На андррйд 10 приложение все работает и на более низких версиях тоже 5,6,9,10 а вот на 11 версии андррйд приложение запускается и сразу вылетает Delphi 10.2 в тулс манагер нет 11 версии чтобы устоновить последняя ток 10 - я дак вот я и спрашиваю как установить пакет sdk андройд 11 в Delphi 10.2 чтобы приложение на 11-м андройд запускались
  8. Нету в Delphi 10.2 http://joxi.ru/5md0WdyS3Bnezm Версии 11 -й Как её скачать ?
  9. Где нету в Delphi 10.2 http://joxi.ru/5md0WdyS3Bnezm Если бы было я и не спрашивал . Просто капилю приложение на всех до 10 -го и включая 10-й Андройд идет приложение , в 11- м Андройде не работает Поставил это : <uses-sdk android:minSdkVersion="%minSdkVersion%" android:targetSdkVersion="%targetSdkVersion%" /> - так по умолчанию указано в AndroidManifest.template.xml в корне проекта, но при редактировании вручную вместо переменных можно указать конкретные значения. Если собирать с помощью Rio, то minSdkVersion = 19, targetSdkVersion = 28. Ошибка ушла что приложение для более ранней версии . Но на 11-м Андройде не в какую не хочет запускается
  10. Не запускается приложение на андройд 11 Delphi 10.2 как скачать в тулс 11 -й андройд
×
×
  • Создать...