Перейти к содержанию
  • Регистрация
  • 0
Alexander Samosyuk

[TBannerAd] Ошибка при загрузке баннера "Ad failed load: 3"

Вопрос

Ребята, помогите решить проблему! Бодаюсь с рекламой уже пару дней, но никак не могу добиться отображения ее в банере. Все делаю по инструкции, но всегда выдает одну и туже ошибку: Ad failed load: 3

TestMode = true

разрешения установлены

AdMOb включен

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Рекомендуемые сообщения

  • 0

https://stackoverflow.com/questions/33566485/failed-to-load-ad-3

Цитата

public static final int ERROR_CODE_NO_FILL

The ad request was successful, but no ad was returned due to lack of ad inventory.

Constant Value: 3

Другими словами, у вас все правильно. Просто для вашего запроса рекламы, сервер не вернул вам баннер. Потому что ему просто либо не чего было вернуть, либо для данного пользователя при данных условиях нечего показать.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
  • 0

я не до конца понимаю такой расклад: при использовании моего AdUnitID реклама не отображается, при использовании чужого все гут!

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
  • 0

Здравствйте. Ребята, пожалуйста, подскажите что я делаю не так.

Пытаюсь отобразить рекламный банер. кидаю на форму BannerAd1, сделал всё как указано в инструкции, но всегда через где-то 14 секунд после запроса банера получаю ответ в событии DidFail такой: "Ad failed to load: 0".

присваивал bannerad1.AdUnitID и своего банера айдишник и тестового, никакого успеха. Размеры тоже не влияют.

TestMode выставляю любой, результат тот же.

разрешения установлены, аккаунт на адмобе заведён, у банера AdSize=auto. Align=top или Client - результат тот же.

сопсна кода-то две строчки

bannerad1.AdUnitID:='ca-app-pub-3940256099942544/6300978111'; // test banner
bannerad1.LoadAd;

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
  • 0
30 минут назад, Ry Koo сказал:

Здравствйте. Ребята, пожалуйста, подскажите что я делаю не так.

Пытаюсь отобразить рекламный банер. кидаю на форму BannerAd1, сделал всё как указано в инструкции, но всегда через где-то 14 секунд после запроса банера получаю ответ в событии DidFail такой: "Ad failed to load: 0".

присваивал bannerad1.AdUnitID и своего банера айдишник и тестового, никакого успеха. Размеры тоже не влияют.

TestMode выставляю любой, результат тот же.

разрешения установлены, аккаунт на адмобе заведён, у банера AdSize=auto. Align=top или Client - результат тот же.

сопсна кода-то две строчки

bannerad1.AdUnitID:='ca-app-pub-3940256099942544/6300978111'; // test banner
bannerad1.LoadAd;

https://stackoverflow.com/questions/38378002/admob-ads-not-loading-failed-to-load-ad-0

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
  • 0

Спасибо за ответ. Насколько я понял из ссылки, проблема в аккаунте адмоба. Тогда во первых почему не работают тестовые айди, а во вторых ждал дней десять и получил от адмоба письмо что мол всё ОК и с платежами и с рекламой, можете пользоваться, но ошибка осталась. всё тот же ноль. Верно я рассуждаю или что-то упустил?

Изменено пользователем Ry Koo

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
  • 0

Мош кому пригодится. В общем адмоб сам, без указания тестдевайса, понял, что мой телефон - телефон разработчика и мне вместо рекламы нулевая ошибка всегда и видимо навсегда приходит. У всех других людей моя программа показывает рекламу без проблем. Так что проблема считай решена.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
  • 0
В 16.02.2019 в 06:12, Ry Koo сказал:

Мош кому пригодится. В общем адмоб сам, без указания тестдевайса, понял, что мой телефон - телефон разработчика и мне вместо рекламы нулевая ошибка всегда и видимо навсегда приходит. У всех других людей моя программа показывает рекламу без проблем. Так что проблема считай решена.

У меня тоже ошибка только код 3, ты меня натолкнул на мысль что может и у меня также как у тя, и действительно. Чтобы проверить на реальном устройстве не загружайте приложение через Android Studio, попробуйте вручную перекинуть apk файл и проверить. Тебе спасибо. А я дурак на трех телефонах тестировал и все через AS кидал)

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Присоединяйтесь к обсуждению

Вы можете написать сейчас и зарегистрироваться позже. Если у вас есть аккаунт, авторизуйтесь, чтобы опубликовать от имени своего аккаунта.

Гость
Ответить на вопрос...

×   Вставлено с форматированием.   Вставить как обычный текст

  Разрешено использовать не более 75 эмодзи.

×   Ваша ссылка была автоматически встроена.   Отображать как обычную ссылку

×   Ваш предыдущий контент был восстановлен.   Очистить редактор

×   Вы не можете вставлять изображения напрямую. Загружайте или вставляйте изображения по ссылке.


  • Похожий контент

    • От erden1
      ЗДравствуйте!
      Подскажите пожалуйста как добавить рекламу в новые ios приложения? Возможно ли это сделать с помощью компонента TBannerAD? И какие есть способы?
    • От dorinmacari
      кроме адМоб как можно добавить другие рекламные плошядки в приложение?
    • От kidrock
      Всем привет. У кого-нибудь получилось запустить приложение c компонентом bannerAD? Вроде бы шёл по этой инструкции , но на мобилке приложение дальше сплэшскрина не идёт. Косяки начинаются, когда я добавляю 
      BannerAD1.LoadAd; 
    • От Gingercat
      Доброго времени суток. Надеюсь, не достал с вопросами (сейчас перепробовал все, что можн, в том числе и переустановку).
       
      Собственно, отложив добавление адмоб на закуску, столкнулся с проблемой - при добавлении, приложение стартует и вылетает. Разрешения прописаны, манифест исправлен - все в порядке. Нашел на форуме ссылку, прочел о Entitlement list.
       
      И тут самое веселое - нет такого пункта в меню Продолбавшись, сообразил, что меню появляется при создании проекта для всех платформ, включая ios. Мну в начале их отрубил - зачем, не знаю. 
       
      И самое интересное - не могу подключить платформу к проекту. Виндовс в меню добавления платформы есть, а вот ios и mac - попросту нет....
       
      На новом проекте, платформы удаляются и добавляются потом без проблем, а у меня только Вин доступно для добавления
       
      В итоге - подключить платформы (дабы появился Entitlement list), я не могу, как результат - рекламу также. Пробовал создавать тестовое приложение с добавлением рекламы - все в порядке, то бишь проблема явно в Entitlement list.
       
      Вот теперь как - переписывать все с нуля, сдурею.
       
      Может кто сталкивался: что за проблема с подключением платформ? Потому что, как скопировать всю программу в новый проект не придумал, и остается перепись с нуля - сумасшедший кусок работы (или может каким то образом можно перенести кучу контролов и кода в новый проект - хотя с трудом верится).
       
      Прложение Android.
       
      Извиняюсь за много букв, и буду благодарен любым, самым фантастическим предположениям.
       
      P.S. может и не морочил бы голову - молча переписал, но там такая куча позиционирования. Дабы не плодить очередную поделку, когда всплывающая клавиатура перекрывает поле для ввода)))) весь интерфейс перестраивается под каждый чих пользователя (юзер френдли, мать его) - освбождается место, поля вверх поднимаются и тд. второй раз такое...))
    • От Adm123
      Всем доброго дня!
      Подскажите, можно ли влепить TBannerAd в качестве child-а на panel, rectangle, layout? Вообще, хоть на что-то..? Никак не получается...
      Я, конечно, не совсем правильно сформулировал вопрос. Чайлдом-то баннер поставить можно, но вот позиционируется align-ом он все равно по главной форме. Как вот с этим бороться?
    • От Alex7wrt
      Добрый день!
      На относительно старом смартфоне Lenovo A390, который был куплен 2 года назад, но только сейчас начал использоваться (пролежал 2 года без работы, только музыку слушали несколько раз), почему-то не отображается реклама - не подгружется TBannerAd (не происходит событие onload). Смартфон под управлением Android 4.0.4, правда с фирменной оболочкой. На двух других устройствах с Android 4.0.3 все нормально отображается.
      При этом Google Play в смартфоне работает, приложения устанавливаются. Время и дата выставлены правильно (читал, что такое может быть из-за их неправильных значений, но тогда и Play Market не работает, и значок WiFi серый), но на этом смарте все ОК, только вот рекламы нет. Кто догадывается о причине, прошу подсказать.
       
      UPD. Проверил сторонние приложения - результат тот же. Но Adblock или чего-то вроде того нигде на смартфоне не заметил.
    • От lokiloki112
      Ребят подскажите в чем дело: в панеле TBannerAd прозрачный и ни как не могу выкинуть его на форму.
      перепробовал версии от 6 до 8 везде одно и тоже.Помогите пожалуйста.

    • От 97mik
      Есть ли в Fire Monkey такой компонент как в XCode, который показывает рекламу?
       

    • От Brovin Yaroslav
      Как использовать компонент отображения встроенной рекламы TBannerAd?
  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу

×
×
  • Создать...