Перейти к содержанию
  • Регистрация
  • 0
Akad

Работа на старых android (<6.0)

Вопрос

Хочу, что бы минимальное требование к версии андроида была, например, 4.4. Соответственно в настройках выбираю SDK api level

...android-sdk-windows\platforms\android-19

На 6 и 7 андроиде работает все замечательно, но если приложение устанавливается на 5 или 4.4 -  при запуске оно падает. Что надо ещё поправить, что бы понизить требуемый API level?

Падает в самом начале ExecJNI,

  if InvokeData.MethodID = nil then
    raise EJNIFatal.CreateRes(@SJNIUnknownMethod);

Студия 10.2. Собирал и на SDK, которая идёт с RAD Studio, и с той, что ставил отдельно. Результат един. NDK выставлял 9, ничего не меняется.
 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Рекомендуемые сообщения

  • 0

в этой версии андроида нету метода который вы используете, он появился позже

смотрите что используете из сторонних компонентов и отключайте, заменяйте

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
  • 0

Из сторонних компонент использую только TMSWebBrowser. В стеке вызовов при падении нет ничего от не Embarcadero. 
 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Присоединяйтесь к обсуждению

Вы можете написать сейчас и зарегистрироваться позже. Если у вас есть аккаунт, авторизуйтесь, чтобы опубликовать от имени своего аккаунта.

Гость
Ответить на вопрос...

×   Вставлено с форматированием.   Вставить как обычный текст

  Разрешено использовать не более 75 эмодзи.

×   Ваша ссылка была автоматически встроена.   Отображать как обычную ссылку

×   Ваш предыдущий контент был восстановлен.   Очистить редактор

×   Вы не можете вставлять изображения напрямую. Загружайте или вставляйте изображения по ссылке.


  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу

×
×
  • Создать...