• 0
Авторизация  
AlexFox51

Google Mobile Ads SDK

Вопросы

Пришло письмо со следующим текстом: "С 23 января 2018 г. мы прекращаем поддержку Google Mobile Ads SDK версий до 7.0.0 для Android и iOS. Чтобы продолжить показ объявлений AdMob после этой даты, перейдите на последнюю версию пакета разработчика."

Я правильно понимаю, что так как у меня в AndroidManifest.xml в строке <meta-data android:name="com.google.android.gms.version" android:value="4323000" />, то реклама показываться с 23 января не будет?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

8 ответов на этот вопрос

  • 1

Насколько я понимаю, речь идет о том, какую версию Google Mobile Ads SDK вы используете. И манифест здесь ни при чем. Google Mobile Ads SDK сейчас является составной частью Google Play Services. И если вы регулярно обновляете SDK под Android, то все должно быть норм.

Если ни так, поправьте меня.

1.PNG.4ace54ec3df7172cf0fd1c66f6dd6944.PNG

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
  • 0

До этого была версия 44 (на данный момент актуальная 46). Как думаете, со старыми приложениями, которые были с версией 44 не будет проблем?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
  • 0

Все же возникли сомнения на этот счет.

Прочел разную инфу и уже не уверен в правильности своего ответа. Не могу понять, нужно обновлять переменную <meta-data android:name="com.google.android.gms.version" android:value="4323000" /> в манифесте или достаточно наличия последней версии SDK.

Гугл говорит, что версии Mobile Ads SDK старше 7.0.0 поддерживаться не будут. Но сейчас он является частью Google Play Services. 

Если проект собран с последней версией Google Play Services, достаточно ли этого? Или же нужно менять и переменную com.google.android.gms.version в манифесте?

Кто может подсказать?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
  • 0

Причем, строка в манифесте:

<meta-data android:name="com.google.android.gms.version" android:value="4323000" />

появляется при включении Admob Service в Project->Options->Entitlement list и в последней версии студии 10.2.2, которая была выпущена недавно.

Значит ли это, что Rad Studio не поддерживает Mobile Ads SDK выше этой версии? Или этот параметр ни на что не влияет, в том числе и на то, что Google перестанет поддерживать Mobile Ads SDK старше 7.0.0?

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти
Авторизация  

  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу