• 0
x11

Добавить SDK 21

Вопрос

Пытаюсь добавить SDK21.

Когда нажимаю Finish, то получаю ошибку, что "A SDK Android SDK 25.2.5 32bit already exists".

 

Что я делаю не так?

 

Screenshot_3.png

Screenshot_4.png

Screenshot_5.png

Screenshot_6.png

Изменено пользователем x11

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

15 ответов на этот вопрос

  • 0

Эм... вы читали ошибку?

Студия дала вам чёткий ответ "Такой СДК уже существует", да и на первом скрине видно, что у вас уже добавлен какой-то "Android SDK 25...", видимо, это он и есть.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
  • 0

У меня такой вопрос. Обязательно ли установленная версия SDK должна соответствовать версии Андроида на смартфоне?

Т.е. на смартфоне 5.0.1, т.е. и в Дельфи должна быть активная версия API 21? Или как?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
  • 0

Да, читал.

В том-то и дело.

Что я хочу установить 21, а получается, что устанавливаю 25?

Тогда КАК установить/добавить 21?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
  • 0
7 минут назад, x11 сказал:

У меня такой вопрос. Обязательно ли установленная версия SDK должна соответствовать версии Андроида на смартфоне?

Т.е. на смартфоне 5.0.1, т.е. и в Дельфи должна быть активная версия API 21? Или как?

Не обязательно. Можно использовать SDK идущее в комплекте со студией.

 

6 минут назад, x11 сказал:

Да, читал.

В том-то и дело.

Что я хочу установить 21, а получается, что устанавливаю 25?

Тогда КАК установить/добавить 21?

Вот тут выберите версию

Снимок.PNG

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
  • 0

аааа, слона-то я и не заметил )))

справа не обратил внимание на полосу прокрутки, а внизу еже есть список выбора

Спасибо :)

nUG9zudAR7mFQP-XHsasSw.png

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
  • 0

Всё равно та же ошибка.

Выбираю 21, а мне пишет "A SDK Android SDK 25.2.5 32bit already exists"

Screenshot_31.png

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
  • 0

Выбираю 26 - ошибка та же.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
  • 0

Ещё раз - у вас уже добавлена эта версия (по мнению Среды). Хотите изменить АПИ, так выберите уже добавленную версию и там измените АПИ или вообще удалите существующую версию и добавьте заново.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
  • 0
9 минут назад, Andrey Efimov сказал:

так выберите уже добавленную версию

 

Добавленную куда?

У меня скачано несколько SDK: 21, 24, 25, 26.

Не помню как, мне удалось в настройках Delphi добавить 25ю (или 24ю). Потом я скачал 21 и 26. И как мне их добавить?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
  • 0
21 минуту назад, x11 сказал:

Добавленную куда?

У меня скачано несколько SDK: 21, 24, 25, 26.

Не помню как, мне удалось в настройках Delphi добавить 25ю (или 24ю). Потом я скачал 21 и 26. И как мне их добавить?

Вы что скачиваете каждый раз полный пакет SDK, ставите в отдельную папку и отдельно добавляете в Студию? (Если так, то объясните, какой в этом смысл?)

На вашем первом скрине видно, что версия 25 уже есть, выберите её и там измените версию АПИ. Есть одно но - это сработает, если ответ на мой вопрос будет отрицательным.

Если ответ положительный, то я вам тут не помогу, т.к. у меня стоит один пакет СДК и уже в нём я скачиваю/обновляю всё, что мне нужно. Например вышла новая версия АПИ, зашёл в SDK Manager и скачал. В студии, просто изменил пути до АПИ.

Вот ваш скрин:

Скрытый текст

Screenshot_3.png.6c7ab311313d733094497b2f9c651b4a.png

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
  • 0
4 минуты назад, Andrey Efimov сказал:

Вы что скачиваете каждый раз полный пакет SDK, ставите в отдельную папку и отдельно добавляете в Студию? (Если так, то объясните, какой в этом смысл?)

Нет, не каждый раз.

Запустил Android SDK Manager, скачал нужные SDK и хочу их в Студию добавить.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
  • 0
7 минут назад, Andrey Efimov сказал:

На вашем первом скрине видно, что версия 25 уже есть, выберите её и там измените версию АПИ.

Я думал, что SDK 25 - это и есть версия API - 25.

Screenshot_35.png

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
  • 0

Смотрите мои скрины:

Студия:

Скрытый текст

Снимок.PNG

Добавил этот же SDK:

Скрытый текст

new.PNG

Студия уже пишет другую версию, я так понял она подхватывает из Android SDK Tools.
Теперь смотрим, что на самом деле у меня установлено:

Скрытый текст


sdkm.PNG

 

sdkm2.PNG

 

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
  • 0

Как всё запутано

пока ничего не понял

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
  • 0

Делайте проще:

Один раз добавили СДК, студия подхватит версию Android SDK Tools. Всё, про эти цифры в студии забываем, они роли не играют.

Далее, допустим вы добавили СДК со скаченными инструментами для АПИ 19, но позже захотелось добавить новое АПИ 26. Заходите в SDK Manager и скачиваете новое АПИ (ваш скрин из предпоследнего сообщения), также обновляете всё, что установлено во вкладке Tools. Теперь заходите в студию, параметры и меняете пути, жмёте ок. Всё, готово. В идеале, надо ещё NDK обновлять.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!


Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.


Войти сейчас

  • Сейчас на странице   0 пользователей

    Нет пользователей, просматривающих эту страницу