Перейти к содержанию
  • Регистрация
  • 0
Steepe_Hare

"Неподдерживаемый тип файла: application/apk"

Вопрос

Извините, что вопрос не совсем по Embarcadero RAD Studio, но нигде не смогли помочь.

Сделал приложение для Android (Berlin 10.1), на смартфоне Samsung Galaxy S5 запускается и работает, а вот на планшете Lenovo IdeaTab A1000-F (с установленной там Android 4.1.2) выдает ошибку:
 
"Неподдерживаемый тип файла: application/apk"

В настройках безопасности планшета стоит галочка "Разрешить установку из неизвестных источников"

Изменено пользователем Andrey Efimov
Перенёс тему в подходящий раздел

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Рекомендуемые сообщения

  • 0

А на Самсунге какая версия Андроида? Может просто созданный вами apk-файл требует версии выше чем 4.1.2

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
  • 0
17 часов назад, voytalexey сказал:

А на Самсунге какая версия Андроида? Может просто созданный вами apk-файл требует версии выше чем 4.1.2

На Самсунге 4.4. А как можно узнать, какую версию Андроида требует apk-файл?

Сколько версий Android SDK вы ставите для Embarcadero?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
  • 0
9 минут назад, Steepe_Hare сказал:

На Самсунге 4.4. А как можно узнать, какую версию Андроида требует apk-файл?

приложение на девайс с неподходящим SDK не установится

34 минуты назад, Steepe_Hare сказал:

Сколько версий Android SDK вы ставите для Embarcadero?

стандартный SDK из комплекта

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
  • 0
17 минут назад, ZuBy сказал:

приложение на девайс с неподходящим SDK не установится

стандартный SDK из комплекта

А где-то в APK прописывается минимально требуемая версия Android?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
  • 0
Только что, Steepe_Hare сказал:

А где-то в APK прописывается минимально требуемая версия Android?

в папке с проектом файл AndroidManifest.template.xml, в нем можно указать нужный SDK

<uses-sdk android:minSdkVersion="%minSdkVersion%" android:targetSdkVersion="%targetSdkVersion%" />

в папке Android\<BuildConfig>\AndroidManifest.xml, можно посмотреть какой сейчас используется

<uses-sdk android:minSdkVersion="14" android:targetSdkVersion="14" />

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
  • 0
2 часа назад, ZuBy сказал:

приложение на девайс с неподходящим SDK не установится

стандартный SDK из комплекта

То есть для того, чтобы приложение запустилось на как можно большом количестве смартфонов и планшетов, нужно качать и использовать как можно старую версию Android SDK?

Или просто проставить минимальную версию Android в манифесте?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
  • 0
25 минут назад, Steepe_Hare сказал:

То есть для того, чтобы приложение запустилось на как можно большом количестве смартфонов и планшетов, нужно качать и использовать как можно старую версию Android SDK?

нет не нужно, вместе со студией идёт "одобренная" версия SDK её и нужно использовать

26 минут назад, Steepe_Hare сказал:

Или просто проставить минимальную версию Android в манифесте?

в minSDKVersion итак стоит 14, но рекомендуется ставить 16

подробней что эти циферки означают, можно посмотреть здесь

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
  • 0
1 час назад, ZuBy сказал:

нет не нужно, вместе со студией идёт "одобренная" версия SDK её и нужно использовать

в minSDKVersion итак стоит 14, но рекомендуется ставить 16

подробней что эти циферки означают, можно посмотреть здесь

так на планшете Леново стоит 4.1.2, а это 16-я версия. То есть должно было запуститься

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Присоединяйтесь к обсуждению

Вы можете написать сейчас и зарегистрироваться позже. Если у вас есть аккаунт, авторизуйтесь, чтобы опубликовать от имени своего аккаунта.

Гость
Ответить на вопрос...

×   Вставлено с форматированием.   Вставить как обычный текст

  Разрешено использовать не более 75 эмодзи.

×   Ваша ссылка была автоматически встроена.   Отображать как обычную ссылку

×   Ваш предыдущий контент был восстановлен.   Очистить редактор

×   Вы не можете вставлять изображения напрямую. Загружайте или вставляйте изображения по ссылке.


  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу

×
×
  • Создать...