Перейти к содержанию
  • Регистрация
  • 0
HyperZen

Проверка подключения к интернету на мобильном устройстве

Вопрос

Добрый день! Сабж, собственно, все примеры, приведенные в интернете, не работают под Delphi Seattle.

Кто-нибудь решал данную задачу?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Рекомендуемые сообщения

  • 0

Нет, к сожалению. Это было первое, что я попробовал :)

Изменено пользователем HyperZen

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
  • 0

Нет, к сожалению.

А можно конкретнее, что происходит, какие ошибки и т.п. Какую версию Андроида используете?

 

Я постараюсь посмотреть в ближайшем будущем, в данный момент обновляется Андроид СДК

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
  • 0

Проверил, в Seattle, с варнингами, но запускается и работает.

 

p.s. Варнинги поправить совсем не проблема, тем более Студия сама пишет, что, где и на что исправить...

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
  • 0

Да, работает! Большое спасибо! У меня ошибка была - использовал FMX.Helpers.Android заменил на новую Android.Helpers и поправил варнинги. Все заработало. (надо разбираться сначала, прежде, чем тему быстрее на форуме постить:)))

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
  • 0
http://fire-monkey.ru/topic/1762-deviceinfo-modul-dlia-polucheniia-informatcii-o-devaise/?hl=udeviceinfo

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
  • 0

Простой способ который у меня на некоторых приложухах стоит 

Цитата

try
IdTCPClient1.ReadTimeout:=2000;
IdTCPClient1.ConnectTimeout:=2000;
IdTCPClient1.Port:=80;
IdTCPClient1.Host:='google.com';
IdTCPClient1.Connect;
IdTCPClient1.Disconnect;
ListBoxItem1.Text:='Статус Подключения: ОК';

except
result:=false;
ShowMessage('Проверьте интернет соединение!');
end;

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
  • 0

этот пример не определяет наличие интернета, Tokyo 10.2.3, тестировал на Android 7.0. проверяет только подключен сам wifi или нет.
вытыкал кабель из роутера, а состояние подключения в приложении всегда True.
в чем может быть проблема?

Изменено пользователем Dev

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Присоединяйтесь к обсуждению

Вы можете написать сейчас и зарегистрироваться позже. Если у вас есть аккаунт, авторизуйтесь, чтобы опубликовать от имени своего аккаунта.

Гость
Ответить на вопрос...

×   Вставлено с форматированием.   Вставить как обычный текст

  Разрешено использовать не более 75 эмодзи.

×   Ваша ссылка была автоматически встроена.   Отображать как обычную ссылку

×   Ваш предыдущий контент был восстановлен.   Очистить редактор

×   Вы не можете вставлять изображения напрямую. Загружайте или вставляйте изображения по ссылке.


  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу

×
×
  • Создать...