• 0
Belov.V.

[Android] Ошибка Failure [INSTALL_FAILED_OLDER_SDK]

Вопросы

После перехода на RX и попытке запуска отладки приложения на девайс с 3.2 при загрузке в устройство выдается вот такая ошибка (в теме). Изменение в настройках Option-SDK (SDK и NDK), как то понижение версии платформы ничего не дает. Play Market тоже отмечает, что приложения собранные на RX имеют Уровень AP 14+

 

Посмотрел глубже - в файле AndroidManifest.xml упорно прописывается:

<uses-sdk android:minSdkVersion="14" android:targetSdkVersion="14" />

и не зависит от того что выбираешь в настройках SDK.

 

Где задается minSDKVersion? Или от каких настроек это значение зависит?

 

Можно конечно в автоматически сгенерированном AndroidManifest.template.xml ручками внести изменение:

<uses-sdk android:minSdkVersion="%minSdkVersion%" заменить к примеру на minSdkVersion="9"

но это как-то кустарно и пока на крайней выход.

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

3 ответа на этот вопрос

  • 0

Это значение не меняется в среде. Поэтому если вам требуется поставить другие значения, значит нужно изменить шаблон манифеста. 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Гость
Эта тема закрыта для публикации ответов.

  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу