Перейти к содержанию
  • Регистрация
  • 0
antarey

Работа с эмулятором BlueStacks из RAD Studio XE5

Вопрос

  1. Кто-то пробовал использовать BlueStacks?
  2. Можно его привязать к студии напрямую?
  3. И как его поднастроить?

Приложения бывает не запускаются, а если и запускаются то никакой контрол не реагирует ? :(

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Рекомендуемые сообщения

  • 0

Небольшая статья о использовании есть на японском языке в официальном японском блоге Embarcadero http://blogs.embarcadero.com/teamj/2014/01/20/4227/.

Воспользуйтесь переводчиком Google. Этого автоматического перевода будет достаточно для понимания сути статьи.

 

Еще обратите внимание на Robert Lawrence Он в своем аккаунте в Google+ публикует успешные результаты использования этого эмулятора с делфи. Просмотрите его посты или свяжитесь с ним напрямую. Я думаю не будет против дать совет, как его подключить к Делфи.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
  • 0

Подключение

  1. Скачиваем эмулятор с официального сайта для Windows или OSX
  2. Устанавливаем эмулятор
  3. Перезагружаем компьютер (сразу после установки, у меня среда не захотела увидеть этот эмулятор)
  4. Запускаем эмулятор идем в настройки и разрешаем отладку. Жмем на кнопку All Apps -> Настройки -> Для разработчиков -> Отладка по USB.
  5. После запуска RAD Studio XE5, эмулятор появится в списке доступных устройств. У него замысловатое название "emulator-5554 (5554)" или производное от этого.
  6. Далее идет обычная работа, как с любым андроид устройством в RAD Studio XE5. Выбираем устройство в списке в Project Manager и запускаем проект (обязательно прочесть Резюме, так как наблюдаются некоторые проблемы с этим эмулятором).

post-1-0-44301000-1394633629_thumb.jpgpost-1-0-80200500-1394633629_thumb.jpgpost-1-0-12836500-1394633630_thumb.jpg

 

Резюме

Проект находится на стадии бетта версии, поэтому ожидать от него 100% работоспособности я бы не стал.

  1. Работает быстрее, чем официальный эмулятор от Google. 
  2. Запуск из среды проходит. Но отладка у меня не заработала.
  3. Иногда приложение не запускается из среды. Помогает перезагрузка эмулятора. Или старт вашего приложения вручную с эмулятора (так как приложение обычно устанавливается)
  4. Работает даже сервис получения фотографий с системной галереи.
  5. Контролы работают, и реагируют на нажатия. Текст вводится и тд.
  6. Наблюдаются некоторые проблемы с использованием физической клавиатуры в эмуляторе. Но виртуальная работает хорошо. Поэтому в критичных местах, где была нужна английская раскладка пользовался виртуальной клавиатурой самого эмулятора.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
  • 0

Для запуска эмулятора с последними версиями среды требуется сделать следующее:

  1. Открыть Deployment Manager. Project-> Deployment
  2. Снять галки с файлов libnative-activity.so
    post-1-0-41264200-1444686883_thumb.png

Более подробную информацию можно найти здесь.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Гость
Эта тема закрыта для публикации ответов.

  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу

×
×
  • Создать...