Перейти к содержанию
  • Регистрация

Поиск сообщества

Показаны результаты для тегов 'debug'.

  • Поиск по тегам

    Введите теги через запятую.
  • Поиск по автору

Тип контента


Форумы

  • Общие вопросы
    • Анимация
    • Графика
    • Стили
    • Базы данных и REST
    • Компоненты
    • Положение, размеры, выравнивание
    • Работа с текстом
    • Приложение и формы
    • Отладка
    • Развертывание приложений
    • Вопросы по языку Object Pascal и RTL
    • Общая информация о TControl
    • События
    • Прочие вопросы
  • Вопросы по платформам
  • Вопросы по использованию RAD Studio
  • Native FGX
  • Обучение
  • Поиск специалистов по FireMonkey
  • Дополнительные ресурсы по FireMonkey
  • Организация работы данного форума
  • Видеокурсы

Поиск результатов в...

Поиск контента, содержащего...


Дата создания

  • Начало

    Конец


Дата обновления

  • Начало

    Конец


Фильтр по количеству...

Регистрация

  • Начало

    Конец


Группа


AIM


MSN


Сайт


ICQ


Yahoo


Jabber


Skype


StackOverflow


Защита от ботов


Город


Интересы

Найдено: 7 результатов

  1. Всем доброго времени! Только что бухтел в одной из тем что другие бухтят вместо действий, и решил сам побухтеть) Дано: Токио 10.2, Макбук, ПАсервер 19. Приложение нормально собирается под айфон, запускается, работает. При пошаговой отладке последние пару недель наблюдаетются непонятные лаги/задержки. Пошаговый переход с одной строки на другую занимает по 20 секунд, причем большую часть времени студия проводит в режиме "Приложение не отвечает". Раньше (пару месяцев назад) такого не было. Грешил на сеть, но сетевых задержек между машиной со студией и маком я не наблюдаю. Есть ли у вас мысли, куда нужно посмотреть/покрутить? Заранее спасибо!
  2. Ошибка при запуске программы на отладку: " Can't open socket: Permission denied Exiting . " кто знает как побороть ? Отладку запускаю на OnePlus3 с Android 8.0.0, драйвера Google USB переустанавливал.
  3. Абракадабровцы утверждают, что под Android студия компилит только для ARM-процессоров. Однако Delphi-приложение запускается на аппарте с Intel-процессором, в котором установлен транслято байт-кода "Houdini". Но отладка не работает. Т.е. из-под студии программа запускается, работает, а студия сразу после старта приложения возвращается в обычный режим редактирования. Пробовал на Lenovo Yoga Tablet 2. У кого-нибудь получилось войти в отладчик в "режиме" Houdini? Или это тупиковая ветвь развития...
  4. Rusland

    Debug сервиса

    У меня частые проблемы с дебагом сервиса (впрочем как и потоков). Какое-то время breakpoint-ы срабатывают, но через некоторое время я не могу попасть внутрь сервиса - дебаг начинает игнорировать точки останова, что я расставляю внутри сервиса. Например, ставлю breakpoint: function TAndroidServiceDM.AndroidServiceStartCommand(const Sender: TObject; const Intent: JIntent; Flags, StartId: Integer): Integer; begin Log('DDD1 service started',[]); // сюда Result := TJService.JavaClass.START_STICKY; end; при вызове сервиса студия (в режиме дебага) зависает и через пару минут выдает: (программа на устройстве естественно тоже зависает и через какое-то время пишет Приложение не отвечает. Закрыть его?) Я пробовал делать Clean/Build сервиса (удалял папкe Android), пробовал удалять из программы сервис и добавлять его заново. Это не помогает. Надоело каждый раз собирать проект заново! Кстати, при установке программы с сервисом Android каждый раз выдает мне предупреждение: Я нажимаю всегда Отклонить - пока не нажмешь, студия висит ждет разрешения на запуск приложения. Что это за сообщение?
  5. Если кому не трудно, объясните почему вместо значения переменной при дебаге я вижу такое сообщение: "Error reading address 0x0: No error". Дебажу на андроиде, делфи ХЕ 8. Нормально ли это?
  6. На виртуальной машине установил XE8 параллельно с XE7. Создал тестовое приложение с ошибкой. Запустил по F9 на телефоне. Отладчик не запускается, ошибку не отлавливает. На Win и iOS работает. Скажите мне, что у Вас работает отладка на андроиде и это не баг XE8, чтоб я вздохнул с облегчением.
  7. Поставил XE8. По F9 и по кнопке не запускается отладочное окно. Пустой проект с настройками по умолчанию. Конфигурация Debug-Debug. В проекте все галочки на отладку установлены. Что не так?
×
×
  • Создать...