Поиск по сайту

Результаты поиска по тегам 'TModel3D'.

  • Поиск по тегам

    Введите теги через запятую.
  • Поиск по автору

Тип публикаций


Категории и разделы

  • Общие вопросы
    • Анимация
    • Графика
    • Стили
    • Базы данных и REST
    • Компоненты
    • Положение, размеры, выравнивание
    • Работа с текстом
    • Приложение и формы
    • Отладка
    • Развертывание приложений
    • Вопросы по языку Object Pascal и RTL
    • Общая информация о TControl
    • События
    • Прочие вопросы
  • Вопросы по платформам
    • Android
    • iOS
    • OSX
    • Windows
    • Windows Phone
    • Linux
  • Вопросы по использованию RAD Studio
    • Лицензирование
    • Сборка проектов
    • Multi-Device Designer
    • Редактор кода
    • Вопросы
  • Обучение
    • Основная информация
    • Вопросы
    • Отзывы
  • Поиск специалистов по FireMonkey
    • Консультации
    • Ищу подрядчика
  • API интернет сервисов
    • ВКонтакте API
    • Google Maps API
    • Yandex деньги
  • Дополнительные ресурсы по FireMonkey
    • Сторонние компоненты
    • Приложения, написанные с использованием FireMonkey
    • Примеры
    • Руководства
    • Шаблоны
    • Статьи и заметки
    • Информация о версиях RAD Studio
    • Новости
  • Организация работы данного форума
    • Правила форума
    • Нарушения правил форума
    • Предложения об организации форума
    • Проблемы
  • Видеокурсы
    • Основная информация
    • Курсы
    • Предложения и голосования за новые курсы
    • Вопросы

Категории

  • Курсы



Фильтр по количеству...

Найдено 3 результата

  1. Не нашёл раздел по 3d на данном форуме, пишу в графике. Админы поправьте, если я не прав. А моя проблема заключается в том, что при динамической загрузке объектов, они разного размера. При этом размер не рандомный вовсе, а просто модель то большая, то маленькая, то просто смещена. Загружаю так: TModel3D.LoadFromFile(''); Модель кинул на форму. При создание динамически тоже самое. И ещё, скажите как правильно чистить TModel3D от подгруженной модели? Чтоб и текстуры удалялись. Реализация TModel3D мне показалось очень странной...
  2. Смотрел вот http://fire-monkey.ru/topic/619-pochemu-u-menia-ne-rabotaet-onclick-po-3d-obektu/, но там ничего не понял, у меня есть форма TForm3D, и на ней TDummy, а на этом TDummy находится TModel3D. Вот при клике на эту модель, нужно чтобы работало событие OnClick. Но оно не работает!
  3. Я работаю на Rad Studio XE7 C++ builder. Нужно загрузить obj-модель в TModel3D из TStream, или из файла, но когда вызываю LoadFromFile, модель стает пустой(если там загружена модель в Design Time). Как решить эту проблему?